/* Dynamic Comments... */

Wednesday, January 25, 2006

Gmail Smart-Delete Button Ver. 0.7.2 Released!

[for FireFox ver 1.5 & Greasemonkey 6.4 users]
NEW! 'Smart-Delete' replacement for Gmail's 'vanilla' delete button.

Wish Gmail's new delete button had all those features you have come to love?
Features like auto-enabling when items are selected and customizable keyboard shortcuts? Well, we're back! Version 7 is up and running. Don't settle for vanilla. Download Smart-Delete Version 7 today!

[Version 7.2 again tweaks the button size - per user issues.
Be patient - I'll eventually get it right!]


Features: User defined keyboard shortcut - User can set which key they would like to use to trigger mail deletion. (The default letter is 'd', but by editing the script file any letter can be used. Just find the following line of code near the beginning of the script:
var TheDeleteKey='d';
And change the key letter to whichever one you like.
Be careful, though, not to select a shortcut already being used by Gmail!)


(Click to view larger.)

Download here: Gmail Smart-Delete Button Ver. 0.7.2
[To install, right-click the above link & choose 'Install User Script...' from context menu.]



Keep those comments and suggestions coming!
I'll try to implement any useful (and reasonable) suggestions you come up with.
Check back often for updates!


Related Tags:
/ / / / /

6 Comments:

Anonymous htiawe said...

Hey, i cant get this version to work. I upgraded from Firefox 1.0.4 to 1.5.1 and now the smart delete button wont work. It will show up, greasemonkey is installed without a problem but when i hit the delete button nothing happens.

4:07 AM, February 03, 2006  
Blogger Paul M. said...

Are you using Greasemonkey 6.4?
With FireFox ver 1.5.x / Greasemonkey 6.4 / Smart-Delete 7.2 I have had no other reports of problems.

8:57 AM, February 03, 2006  
Anonymous htiawe said...

Yeah, gresemonkey 0.6.4 and the latest script. Just wont work.

1:18 AM, February 18, 2006  
Anonymous Chris Hyams said...

some time this week, the delete button stopped showing up. this has been confirmed by 10 or so people i know, all of us with 0.6.4 / 7.2 / 1.5.

7:32 AM, March 17, 2006  
Anonymous spikey.mcmarbles@gmail.com said...

I was having the same issue as chris, but sometime this morning it suddenly started working again. Presumably Google implemented some sort of change, and ended up backing it out.

12:05 PM, March 18, 2006  
Blogger Paul M. said...

Yeah,
It looks like they backtracked. I had a partial fix that I was going to post today (it fixed only the upper button), but I'll wait and see what they are going to do...

9:05 AM, March 19, 2006  

Post a Comment

<< Home